woo-3-4

WooCommerce 3.4, GDPR, GeoLite2 y más novedades

¡WooCommerce 3.4 en la ha sido lanzado!

La version 3.4 ha estado en desarrollo desde enero y ha tenido más de 2140 confirmaciones de 80 contribuidores.

Esta version es un lanzamiento “menor”; debería ser compatible con versiones anteriores de sitios con versiones de WooCommerce superiores a 3.0. Por supuesto, recomendamos asegurarse de que sus extensiones y temas sean compatibles antes de la actualización y hacer copias de seguridad para su tranquilidad.

Características GDPR, ajustes y configuraciones

Este lanzamiento presenta varias herramientas, ajustes y configuraciones:

  • Herramientas de anonimato, borrado y exportación de datos de usuario.
  • Configuración para permitir la limpieza o eliminación automática de datos.
  • Nuevas configuraciones de personalizador para campos de pago y avisos de política en la página de pago.
  • Modifica el registro para garantizar que los datos personales no se registren.

Estas características se vinculan y requieren WordPress 4.9 para funcionar.

Para obtener más información acerca de estas características, puede leer el desglose detallado.

También aqui puede encontrar una serie de publicaciones en el blog principal de WooCommerce explicando cómo preparar su sitio para GDPR, que todos los propietarios de tiendas deberían leer, y los desarrolladores deberían pasarlo a sus clientes.

Integracion con GeoLite2

WooCommerce utiliza la base de datos MaxMind GeoLite para la geolocalización durante el checkout para así seleccionar automáticamente el país correcto del cliente. La base de datos GeoLite ha sido descontinuada por MaxMind, y GeoLite2 es el reemplazo. Esta versión agrega compatibilidad e integra WooCommerce con GeoLite2 para garantizar que la geolocalización continúe funcionando correctamente en el futuro. Todo el proceso es automático y no es necesario que el propietario de la tienda realice ninguna otra acción para que esto suceda.

La biblioteca que se integra con GeoLite2 requiere una versión mínima de PHP de 5.4. Como paso necesario, WooCommerce no admitirá la geolocalización con GeoLite2 en versiones PHP inferiores a 5.4.

En los sitios que esten corriendo esas versiones de PHP la geolocalizacion sera realizada mediante APIs. La geolocalizacion basada en API es un metodo mas lento, y es recomendable que actualice su version de PHP si esta corriendo una inferior a la 5.4.

Si necesita ayuda para upgradear la version de PHP, aqui puede encontrar una guia.

Características para propietarios de tiendas

Aquí hay algunas otras características nuevas que pueden ser de utilidad al usar WooCommerce:

  • Un widget de tablero multisitio que muestra información de pedidos de todos los sitios.
  • Soporte de correo electrónico Wildcard para restricciones de cupones. Al utilizar el carácter comodín, puede configurar cupones restringidos a grupos de direcciones de correo electrónico similares (cuentas de correo electrónico .edu, cuentas de correo electrónico corporativo de un determinado negocio, etc.).
  • Los usuarios ahora pueden establecer su nombre para mostrar en la página Mi cuenta.
  • Mejoras en la búsqueda de productos de administrador, incluida la posibilidad de buscar múltiples productos en la misma consulta.

Caracteristicas para constructores de tiendas y desarrolladores

Si está creando tiendas para clientes o simplemente está desarrollando sobre WooCommerce, aquí hay algunos detalles nuevos a su disposición:

  • Hemos movido todos los estilos de Photoswipe a su propio archivo CSS para que sean fáciles de quitar si es necesario.
  • Puede declarar una limpieza de datos en la llamada de la configuración de la API.
  • Agregamos compatibilidad con tipos de entrada HTML5 adicionales para configuraciones y formularios de pago.
  • Nuevos filtros y acciones para aumentar la personalización de WooCommerce.

Además de las nuevas características, hay una variedad de ajustes menores y arreglos en esta versión menor. Aqui puede ver la lista completa de cambios si está interesado.

Actualizando a 3.4

La 3.4 es una actualización menor y debe ser compatible con sitios que ejecuten cualquier versión de WooCommerce mayor o igual a 3.0. Todavía recomendamos realizar pruebas y realizar copias de seguridad antes de actualizar para estar seguros.

Nota: hay algunas rutinas de actualización de base de datos posteriores a la actualización que deben ejecutarse después de la misma. Estos pueden ejecutarse por un tiempo si tiene una gran cantidad de datos en su base de datos.

Si eres un desarrollador y de alguna manera has perdido la versión beta y RC, la siguiente información puede ser útil.

Items obsoletos en 3.4

  • WC_Geo_IP se ha considerado obsoleta debido a que la base de datos GeoLite ha sido discontinuada.
  • La columna Product Type column en la pantalla de productos del administrador ha sido removida y lanzada como plugin. Aqui puede encontrar mas informacion. Si desea mantener la columna, simplemente instale el plugin y listo.
  • WC_Widget_Product_Tag_Cloud::_get_current_taxonomy se ha considerado obsoleta y se ha reemplazado por WC_Widget_Product_Tag_Cloud::get_current_taxonomy.
  • WC_Widget_Product_Tag_Cloud::_topic_count_text se ha considerado obsoleta y se ha reemplazado por  WC_Widget_Product_Tag_Cloud::topic_count_text.

Como se testeo 3.4

La version 3.4 beta fue lanzada el 18 de abril de 2018 y permaneció en beta hasta el 9 de mayo de 2018. Durante este tiempo se probo internamente, las propias extensiones y temas,  temas premium populares, se hicieron algunas actualizaciones administradas para clientes reales en sitios para tomar nota de cualquier conflicto o error antes del lanzamiento público y probar la actualización en WooCommerce.com.

Comparte este post.